Petri.co.il forums Home Forums Start Page Forums Frequently Asked Questions FAQ Member List Members List
Go Back   Petri IT Knowledgebase Forums > Networking > General Networking
Petri.co.il is happy to award RicklesP the title of Most Valuable Member !!!
Register Calendar Calendar Search Petri IT Knowledgebase Forums Search Todays Posts Today's Posts Mark Forums Read
Notices

Emails from one domain uses wrong MX record.

Emails from one domain uses wrong MX record.

this thread has 8 replies and has been viewed 1675 times

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #1  
Old 30th April 2012, 16:58
zang8027 zang8027 is offline
Casual
Casual
 
 Join Date: Oct 2011
  6 month star 12 month star
 Posts: 19
 Reputation: zang8027 is on a distinguished road (10)
Default [resolved] Emails from one domain uses wrong MX record.

I am not sure if anyone is able to help or if it is the right forum, but has anyone had an issue where the wrong MX record is used?

We have two MX records. One has a value of 10 and one has a value of 20. All emails come in to the 10 record, or lower value. One domain though is getting bounces, and the bounce shows that its trying to use our backup MX record, that does not have sendmail running on it.

Anyone know why a certain domain could use the wrong MX record, even though there is a lower value for the other MX record? Anyone seen this before?

Last edited by zang8027; 30th April 2012 at 21:29.. Reason: resolved
  #2  
Old 30th April 2012, 17:03
Ossian Ossian is offline
Administrator
 
 Join Date: Nov 2003
  6 month star 12 month star
 Location: Bonnie Scotland
 Posts: 16,661
  Send a message via Skype™ to Ossian
 Reputation: Ossian has a brilliant futureOssian has a brilliant futureOssian has a brilliant futureOssian has a brilliant futureOssian has a brilliant futureOssian has a brilliant futureOssian has a brilliant futureOssian has a brilliant futureOssian has a brilliant futureOssian has a brilliant futureOssian has a brilliant future (1520)
Default Re: Emails from one domain uses wrong MX record.

DNS issues on their side, presumably

I suspect there is nothing you can do except pass your evidence on to their IT guru
__________________
Tom Jones
MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
PhD, MSc, FIAP, MIITT
IT Trainer / Consultant
Ossian Ltd
Scotland

** Remember to give credit where credit is due and leave reputation points where appropriate **
  #3  
Old 30th April 2012, 17:15
L4ndy L4ndy is offline
Moderator
 
 Join Date: May 2006
  6 month star 12 month star
 Location: Liverpool, UK
 Posts: 2,634
 Reputation: L4ndy is a glorious beacon of lightL4ndy is a glorious beacon of lightL4ndy is a glorious beacon of lightL4ndy is a glorious beacon of lightL4ndy is a glorious beacon of lightL4ndy is a glorious beacon of light (541)
Default Re: Emails from one domain uses wrong MX record.

A couple of things I can think of would be either a connection has failed to be established or the TTL value on the old MX record has been setup wrong and it is still cached on the sending email server's DNS server.
Can you PM me the domain name if you don't want it to be public?
__________________
Caesar's cipher - 3

ZKHQ BRX HYHQWXDOOB GHFLSKHU WKLV BRX ZLOO UHDOLVH LW ZDV D ZDVWH RI WLPH!

SFX JNRS FC U6 MNGR
  #4  
Old 30th April 2012, 17:18
joeqwerty's Avatar
joeqwerty joeqwerty is offline
Moderator
 
 Join Date: Jul 2007
  6 month star 12 month star
 Posts: 4,858
 Reputation: joeqwerty is a splendid one to beholdjoeqwerty is a splendid one to beholdjoeqwerty is a splendid one to beholdjoeqwerty is a splendid one to beholdjoeqwerty is a splendid one to beholdjoeqwerty is a splendid one to behold (664)
Default Re: Emails from one domain uses wrong MX record.

RFC 5321 States:

When the lookup succeeds, the mapping can result in a list of
alternative delivery addresses rather than a single address, because
of multiple MX records, multihoming, or both. To provide reliable
mail transmission, the SMTP client MUST be able to try (and retry)
each of the relevant addresses in this list in order, until a
delivery attempt succeeds. However, there MAY also be a configurable
limit on the number of alternate addresses that can be tried. In any
case, the SMTP client SHOULD try at least two addresses.


So it could be the case that the sending MTA is attempting to connect to your "primary" MX, is failing, and is then connecting to your "secondary" MX.
  #5  
Old 30th April 2012, 17:25
scurlaruntings's Avatar
scurlaruntings scurlaruntings is offline
Senior Member
Someone to look up to
 
 Join Date: Apr 2008
  6 month star 12 month star
 Location: London England
 Posts: 1,009
  Send a message via MSN to scurlaruntings
 Reputation: scurlaruntings will become famous soon enough (97)
Default Re: Emails from one domain uses wrong MX record.

Can also be a spammer. They tend to use the higher cost MX record for UCE.
  #6  
Old 30th April 2012, 18:27
zang8027 zang8027 is offline
Casual
Casual
 
 Join Date: Oct 2011
  6 month star 12 month star
 Posts: 19
 Reputation: zang8027 is on a distinguished road (10)
Default Re: Emails from one domain uses wrong MX record.

I am going to contact the administrator on their side to see if they can resolve proper MX records. I will post solution. Thanks for everything so far!
  #7  
Old 30th April 2012, 21:28
zang8027 zang8027 is offline
Casual
Casual
 
 Join Date: Oct 2011
  6 month star 12 month star
 Posts: 19
 Reputation: zang8027 is on a distinguished road (10)
Default Re: Emails from one domain uses wrong MX record.

it was looking like the emails actually came in when we were testing our fail over so that would make sense. Did not happen to notice the time on the email at first.
  #8  
Old 1st May 2012, 11:21
tehcamel's Avatar
tehcamel tehcamel is offline
Moderator
 
 Join Date: Mar 2009
  6 month star 12 month star
 Location: Melbourne
 Posts: 5,563
  Send a message via Skype™ to tehcamel
 Reputation: tehcamel is a splendid one to beholdtehcamel is a splendid one to beholdtehcamel is a splendid one to beholdtehcamel is a splendid one to beholdtehcamel is a splendid one to beholdtehcamel is a splendid one to behold (656)
Default Re: Emails from one domain uses wrong MX record.

on a side note.. might it be worthwhile to make sure Sendmail is running on your 2MX ?
__________________

Melbourne IT Support


Please do show your appreciation to those who assist you by leaving Rep Point
  #9  
Old 3rd May 2012, 21:44
biggles77's Avatar
biggles77 biggles77 is offline
Administrator
 
 Join Date: Dec 2003
  6 month star 12 month star
 Location: Nowhere that I like.
 Posts: 11,059
 Reputation: biggles77 is a splendid one to beholdbiggles77 is a splendid one to beholdbiggles77 is a splendid one to beholdbiggles77 is a splendid one to beholdbiggles77 is a splendid one to beholdbiggles77 is a splendid one to beholdbiggles77 is a splendid one to behold (809)
Default Re: Emails from one domain uses wrong MX record.

Does the lower cost MX Record have a typo in it by any chance? (Assuming I am actually understanding the problem)
__________________
"There I stood at the bar, wearing a Mae West, no jacket, and beginning to leak blood from my torn boot. None of the golfers took any notice of me - after all, I wasn't a member!" Kenneth Lee - after being shot down during the Battle of Britain on the 18th August 1940.

************************************************** **********************
** Remember to give credit where credit is due and leave reputation points where appropriate **
************************************************** **********************
Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrong SMTP and X400 record Najib Exchange 2000 / 2003 7 4th January 2011 11:34
Additional mailboxes - emails in wrong sent items folder tehcamel Exchange 2007 / 2010 / 2013 10 29th October 2010 10:35
mx record for a different domain kejs DNS 1 27th August 2010 13:11
MX Record from other domain? AndyR Exchange 2000 / 2003 2 26th March 2010 06:43
Outlook 2003 - wrong Date/Time shown on emails intersilver Outlook 0 11th June 2008 15:55


All times are GMT +3. The time now is 19:04.

Steel Blue 3.5.4 vBulletin Style ©2006 vBEnhanced
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
 

Valid XHTML 1.0!   Valid CSS!

Copyright 2005 Daniel Petri