Petri.com forums Home Forums Start Page Forums Frequently Asked Questions FAQ Member List Members List
Go Back   Petri IT Knowledgebase Forums > Messaging Software > Exchange 2000 / 2003
Petri.com is happy to award RicklesP the title of Most Valuable Member !!!
Register Calendar Calendar Search Petri IT Knowledgebase Forums Search Todays Posts Today's Posts Mark Forums Read
Notices

Unable to replay the log files to the Recovery Storage Group

Unable to replay the log files to the Recovery Storage Group

this thread has 1 replies and has been viewed 3024 times

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #1  
Old 30th June 2009, 19:26
nesanjoseph nesanjoseph is offline
Casual
Casual
 
 Join Date: Jun 2009
  6 month star 12 month star
 Location: Chennai
 Posts: 16
 Reputation: nesanjoseph is on a distinguished road (10)
Unhappy Unable to replay the log files to the Recovery Storage Group

Dear all,

I have a problem here and believe that someone could help me get the issues resolved. Here is my scenario,

- I backed up "First Storage Group" that contains 'Mailbox Store' and 'Public Folder Store'.
- The full backup and the incremental backups were successful.
- I lost a specific mailbox. Hence I wanted to restore just that mailbox upto-date(as in the backup) and NOT ALL the mailboxes.
- Hence, I planned to restore the 'Mailbox Store' to the 'Recovery Storage Group' along with the log files(because numerous transactions are in those log files).
- When I restored the 'Mailbox Store' alone(as Public Folder Store cannot be restored to the 'Recovery Storage Group') along with the log files, I could see the following errors/failures.

Problem 1: The restored database 'Mailbox Store' was in 'Dirty Shutdown' state.

Problem 2: I am not able to replay the log files to the 'Recovery Storage Group' and when I manually try to do so, eseutil throws error and logs replay does not start.


I can resolve the 'Problem 1' by bringing the 'Mailbox Store' (now present in the Recovery Storage Group) to 'Clean Shutdwown' state by repairing the database. But I do not know how to replay the log files to the Recovery Storage Group. Can someone please help me on this issue? Is it possible to replay the log files to a Recovery Storage Group when restoring a 'Mailbox Store' alone and not the Public Folder Store? I suspect that the log file replay failure is due to the Public Folder Store only, because the log files would have got the transactions of the Public Folders too. Any way to recover the data from the log files also (by replaying them to the Recovery Storage Group)?

Exchange Version: Exchange Server 2003
OS version : Windows Server 2003 (32-bit)


Many thanks in advance,
Nesan Joseph R.
  #2  
Old 3rd July 2009, 12:58
nesanjoseph nesanjoseph is offline
Casual
Casual
 
 Join Date: Jun 2009
  6 month star 12 month star
 Location: Chennai
 Posts: 16
 Reputation: nesanjoseph is on a distinguished road (10)
Arrow Re: Unable to replay the log files to the Recovery Storage Group

Hi all,

Adding to my previous post I just want to show you the results of some comamnds i ran to replay the log files. Any help is appreciated if there is a way to mount the database with all required logs replayed, without using '/p' switch(repair)!

The following are the command results of the steps i tried to restore the database to a Recovery Storage Group.

1) I ran the eseutil /mh command after restoring the exchange data to the RSG. please find the output.

----------------------------------8<---------------------------------------
C:\Program Files\Exchsrvr\RSG>"C:\Program Files\Exchsrvr\bin\eseutil.exe" /mh "Mailbox Store (DUALSERVER).edb"

Microsoft(R) Exchange Server Database Utilities
Version 6.5
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating FILE DUMP mode...
Database: Mailbox Store (DUALSERVER).edb

File Type: Database
Format ulMagic: 0x89abcdef
Engine ulMagic: 0x89abcdef
Format ulVersion: 0x620,9
Engine ulVersion: 0x620,9
Created ulVersion: 0x620,9
DB Signature: Create time:05/19/2009 13:32:22 Rand:1463303647 Computer:
cbDbPage: 4096
dbtime: 657864 (0-657864)
State: Dirty Shutdown
Log Required: 462-463
Streaming File: Yes
Shadowed: Yes
Last Objid: 542
Scrub Dbtime: 0 (0-0)
Scrub Date: 00/00/1900 00:00:00
Repair Count: 0
Repair Date: 00/00/1900 00:00:00
Last Consistent: (0x1CC,29,4E) 06/30/2009 11:36:48
Last Attach: (0x1CC,30,151) 06/30/2009 11:41:58
Last Detach: (0x0,0,0) 00/00/1900 00:00:00
Dbid: 1
Log Signature: Create time:05/19/2009 13:32:02 Rand:1463289603 Computer:
OS Version: (5.2.3790 SP 2)

Previous Full Backup:
Log Gen: 460-460 (0x1cc-0x1cc)
Mark: (0x1CC,86,40)
Mark: 06/30/2009 12:36:14

Current Incremental Backup:
Log Gen: 460-462 (0x1cc-0x1ce)
Mark: (0x1CF,8,16)
Mark: 06/30/2009 12:38:32

Current Full Backup:
Log Gen: 462-466 (0x1ce-0x1d2)
Mark: (0x1CF,9,60)
Mark: 06/30/2009 12:39:53

Current snapshot backup:
Log Gen: 0-0 (0x0-0x0)
Mark: (0x0,0,0)
Mark: 00/00/1900 00:00:00

cpgUpgrade55Format: 0
cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

Operation completed successfully in 1.94 seconds.

---------------------------------->8---------------------------------------


2) The shutdown state is 'Dirty'. I do not know why the shutdown state is always 'Dirty' whenever i try to restore a database to RSG!. Since I did not choose 'Last Restore Set' while restoring the data, I tried to replay the log files manually. Please find the output of eseutil /cm command.

----------------------------------8<---------------------------------------

D:\tempologs\RSG>"C:\Program Files\Exchsrvr\bin\eseutil.exe" /cm .

Microsoft(R) Exchange Server Database Utilities
Version 6.5
Copyright (C) Microsoft Corporation. All Rights Reserved.

Restore log file: D:\tempologs\RSG

Restore Path: D:\tempologs\RSG
Annotation: Microsoft Information Store
Server: DUALSERVER
Backup Instance: RSG
Target Instance:
Restore Instance System Path:
Restore Instance Log Path:

Databases: 1 database(s)
Database Name: Mailbox Store (DUALSERVER)
GUID: 08B2D6FF-F0D1-4522-7BA8452278A949DC
Source Files: D:\local_exchange_restore\C-Drive\Program
Files\Vembu\StoreGrid\plugin-data\xchangeserver\FirstStorageGroup\DUALSERVER\RS
G\Mailbox Store (DUALSERVER)\Mailbox Store (DUALSERVER).edb D
Destination Files: C:\Program Files\Exchsrvr\RSG\Mailbox Sto
re (DUALSERVER).edb C:\Program Files\Exchsrvr\RSG\Mailbox Store (DUALSERVER).stm




Log files range: E00001CE.log - E00001D2.log
Last Restore Time: Thu Jan 01 05:30:00 1970

Recover Status: recoverNotStarted
Recover Error: 0x00000000
Recover Time: Tue Jun 30 13:03:05 2009

Operation completed successfully in 0.15 seconds.

---------------------------------->8---------------------------------------


3) I ran eseutil /cc command now. here is the output. I am worried about the error "Operation terminated with error -939585531 (Error returned from a callback function call (0xFFFFFDE0)".

----------------------------------8<---------------------------------------
D:\tempologs\RSG>"C:\Program Files\Exchsrvr\bin\eseutil.exe" /cc

Microsoft(R) Exchange Server Database Utilities
Version 6.5
Copyright (C) Microsoft Corporation. All Rights Reserved.

Using restore environment
Restore log file: D:\tempologs\RSG

Restore Path: D:\tempologs\RSG
Annotation: Microsoft Information Store
Server: DUALSERVER
Backup Instance: RSG
Target Instance:
Restore Instance System Path:
Restore Instance Log Path:

Databases: 1 database(s)
Database Name: Mailbox Store (DUALSERVER)
GUID: 08B2D6FF-F0D1-4522-7BA8452278A949DC
Source Files: D:\local_exchange_restore\C-Drive\Program
Files\Vembu\StoreGrid\plugin-data\xchangeserver\FirstStorageGroup\DUALSERVER\RS
G\Mailbox Store (DUALSERVER)\Mailbox Store (DUALSERVER).edb D
Destination Files: C:\Program Files\Exchsrvr\RSG\Mailbox Sto
re (DUALSERVER).edb C:\Program Files\Exchsrvr\RSG\Mailbox Store (DUALSERVER).stm




Log files range: E00001CE.log - E00001D2.log
Last Restore Time: Thu Jan 01 05:30:00 1970

Recover Status: recoverNotStarted
Recover Error: 0x00000000
Recover Time: Tue Jun 30 13:03:05 2009

Restoring ....
Restore to server: DUALSERVER
Target Instance: RSG
Operation terminated with error -939585531 (Error returned from a callback function call (0xFFFFFDE0).
) after 8.469 seconds.

---------------------------------->8---------------------------------------


I am not sure what is the issue. Please advise. Is there any other method should i follow to restore a mailbox store to a Recovery Storage Group? hard recovery, soft recovery etc...! What step am I missing?

Many thanks,
Nesan Joseph R.
Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Recovery Storage Group: no mailboxes match the matching criteria backspace Exchange 2007 / 2010 / 2013 3 26th June 2009 00:04
Log of mounting/demounting storage group ekrengel Exchange 2000 / 2003 2 20th May 2008 23:29
Restore information store into the recovery storage group avipenina Exchange 2000 / 2003 2 22nd February 2008 09:22
First Storage Group\ Mailbox Store, Public Folders and Log Files corrupt panky Exchange 2000 / 2003 1 19th December 2005 15:36
Recovery storage group johnwong2046 Exchange 2000 / 2003 1 19th July 2005 09:40


All times are GMT +3. The time now is 13:05.

Steel Blue 3.5.4 vBulletin Style ©2006 vBEnhanced
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
 

Valid XHTML 1.0!   Valid CSS!

Copyright 2005 Daniel Petri