Petri.com forums Home Forums Start Page Forums Frequently Asked Questions FAQ Member List Members List
Go Back   Petri IT Knowledgebase Forums > Messaging Software > Exchange 2007 / 2010 / 2013
Petri.com is happy to award RicklesP the title of Most Valuable Member !!!
Register Calendar Calendar Search Petri IT Knowledgebase Forums Search Todays Posts Today's Posts Mark Forums Read
Notices

Cant Receive Emails with Exchange 2010

Cant Receive Emails with Exchange 2010

this thread has 5 replies and has been viewed 63787 times

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #1  
Old 22nd December 2009, 21:48
Brando Brando is offline
Casual
Casual
 
 Join Date: Dec 2009
  6 month star 12 month star
 Posts: 2
 Reputation: Brando is on a distinguished road (10)
Default Cant Receive Emails with Exchange 2010

Hello All,

I have Exchange 2010 running on Windows 2008 R2 Ent server and cannot receive emails externally, however, I can send emails externally and internally.

The following is the configuration on the Server configuration Hub transport.

Hub transport connects directly to the Internet, so external SMTP gateway is used.

Hub transport:

2 send connectors enabled, client and default with anti-spam enabled with default settings.

Default Send Connector:

Specify the FQDN this connector will provide = serv01.domain.com
Network Local = All IPv6 and IPv4 with port 25
Network receive mail from remote servers = 0.0.0.0 255.255.255.255
Authentication = TLS only, enable Domain security unchecked
Permission groups = All checked except partners

Internal DNS lookups uses the network card and External DNS lookups uses 2 external DNS IP addresses.

MX and A records are alread setup with my ISP and is working as previously i had Windows 2003 R2 and Echange 2003 running.

Any help would be appreciated as I dont know where else to check.

Brando
  #2  
Old 23rd December 2009, 13:14
shauncroucher's Avatar
shauncroucher shauncroucher is offline
Casual
It's not a coincidence
 
 Join Date: Jun 2009
  6 month star 12 month star
 Location: Surrey
 Posts: 74
 Reputation: shauncroucher is on a distinguished road (13)
Default Re: Cant Receive Emails with Exchange 2010

It is receive connectors you should be concerned with here.

Exchange Management console --> Server config --> Hub --> Receive connectors.

If you are using port forwarding from a router to your server, check that you have this forwarding to your new server.

From outside network on a PC run the following from a command prompt:

nslookup -q=mx example.com

where example.com is your domain. Take a note of the MX record FQDN. ie mail.example.com

Now type:

telnet mail.example.com 25

where mail.example.com is the MX record.

Do you get a gretting or a connect failed?

If connect failed, repeat the exercise from the server directly. You will have to enable telnet on the server to do this.


Shaun
  #3  
Old 23rd December 2009, 13:34
FischFra FischFra is offline
Member
Here to help
 
 Join Date: Aug 2009
  6 month star 12 month star
 Location: Leipzig - Germany
 Posts: 432
 Reputation: FischFra will become famous soon enough (62)
Default Re: Cant Receive Emails with Exchange 2010

Just uncheck TLS, this would set Authentication to nothing, but I would not do this on the default receive connector instead I would create a new one named something like Internet-In.

For Authentication don't check anything for Permission Groups just check Anonymous users, this should do the trick.
  #4  
Old 23rd December 2009, 14:02
shauncroucher's Avatar
shauncroucher shauncroucher is offline
Casual
It's not a coincidence
 
 Join Date: Jun 2009
  6 month star 12 month star
 Location: Surrey
 Posts: 74
 Reputation: shauncroucher is on a distinguished road (13)
Default Re: Cant Receive Emails with Exchange 2010

You do not need to untick TLS, this is there to allow servers to use TLS if available. It will not interfere with non-TLS anonymous connections.

If you do not need POP\SMTP or IMAP\SMTP connections then you can remove the authentication options if you wish. It is a good security practice to do so if unneeded. However, this will also not affect anonymous connections.

Shaun
  #5  
Old 23rd December 2009, 19:18
Brando Brando is offline
Casual
Casual
 
 Join Date: Dec 2009
  6 month star 12 month star
 Posts: 2
 Reputation: Brando is on a distinguished road (10)
Default Re: Cant Receive Emails with Exchange 2010

Shaun,

When i tried telnet mail.example.com 25 from outside and inside the network and directly on the server, i am getting the following;

nslookup -q=mx example.com is dislaying the expected results.


421 4.3.2 service not available

Brando
  #6  
Old 30th December 2009, 21:54
shauncroucher's Avatar
shauncroucher shauncroucher is offline
Casual
It's not a coincidence
 
 Join Date: Jun 2009
  6 month star 12 month star
 Location: Surrey
 Posts: 74
 Reputation: shauncroucher is on a distinguished road (13)
Default Re: Cant Receive Emails with Exchange 2010

This could be caused by a firewall. Are there any firewalls on the server at all?

So you are running telnet from the server directly?

Can you check the network tab of the receive connector and note if there are any unusual IP restrictions there. Does it allow all IP's to connect?

Shaun
Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Exchange SBS 2003 Unable to receive emails from certain domains manorite SBS 2000 / 2003 / 2008 / 2011 24 7th June 2009 18:29
Exchange 2003 sp2 can Sent but wont receive emails kb7rnh Exchange 2000 / 2003 2 15th May 2009 16:13
Exchange 2003 - Unable To Receive External Emails Joe Awoyinka Exchange 2000 / 2003 24 1st April 2009 20:39
How to receive emails in Exchange 2007 HANIF Exchange 2007 / 2010 / 2013 4 13th August 2008 01:23
exchange 2003 does not receive emails maria42 Exchange 2000 / 2003 3 7th May 2007 23:12


All times are GMT +3. The time now is 01:46.

Steel Blue 3.5.4 vBulletin Style ©2006 vBEnhanced
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
 

Valid XHTML 1.0!   Valid CSS!

Copyright 2005 Daniel Petri