Petri.co.il forums Home Forums Start Page Forums Frequently Asked Questions FAQ Member List Members List
Go Back   Petri IT Knowledgebase Forums > Messaging Software > Exchange 2007 / 2010 / 2013
Petri.co.il is happy to award RicklesP the title of Most Valuable Member !!!
Register Calendar Calendar Search Petri IT Knowledgebase Forums Search Todays Posts Today's Posts Mark Forums Read
Notices

Public folder migration - Exchange 2003 to Exchange 2010

Public folder migration - Exchange 2003 to Exchange 2010

this thread has 3 replies and has been viewed 30302 times

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #1  
Old 17th February 2011, 15:00
outstream outstream is offline
Casual
Casual
 
 Join Date: Sep 2008
  6 month star 12 month star
 Posts: 51
 Reputation: outstream is on a distinguished road (15)
Default Public folder migration - Exchange 2003 to Exchange 2010

Hi All,

I am in the process of doing a test migration from SBS 2003 to SBS 2011.

At the moment I am on the stage to replicate public folder store from SBS 2003 to SBS 2011.
  • I have done "Move all replicas" on public folder store at SBS 2003 side of the stuff. It showed me moving all the public folder hierarchy nicely.
  • on SBS 2011, i`ve been issuing Get-PublicFolderStatistics -Server <servername> from time to time and have been observing changes in itemcount. However, this carried on happening for just a little amount of time.
  • On Exchange 2003, I have set the replication bit "Always run", replication interval "5 mins" and Message size "524288" (.5 gb)
  • I have mirrored same settings on Exchange 2010 side of things.
  • In addition to that, I`ve got the replication priority set as "Urgent"
  • At Exchange 2010 , when I do Get-PublicFolder \ -Recurse, I do see all the public folders listed and their hierarchy.
  • Moreover, I enabled diagnostic and logging bit on both servers for Replication Errors, Replication Conflicts, Replication outgoing messages etc. In events logs I can see messages coming and going fine.

Now well the problem is, I am not confident that replication is occurring at all. Its been 4 days now that servers are in this state, and there has not been any progress in item count when I do Get-PublicFolderStatistics -Server <servername>

I am new to this and still learning. How can I check if the message flow between servers is going fine, or any other troubleshooting tips?

Thanks all
  #2  
Old 18th February 2011, 00:46
Sembee's Avatar
MVP Sembee Sembee is offline
MVP
MVP
 
 Join Date: Apr 2006
  6 month star 12 month star
 Location: Newbury, UK
 Posts: 6,464
 Reputation: Sembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud of (1116)
Default Re: Public folder migration - Exchange 2003 to Exchange 2010

Public Folder replication is very conservative, and it is not unknown for it to take a week or more. You can force things along on a per folder basis through ESM by using the Send Content Now command (right click on the folder to see that). As long as the numbers are going up, then replication is happening. It just doesn't happen very fast.

Personally I don't use the Move All Replicas script because it moves everything and this can cause an issue with existing users. My usual method is to use add-replicatopfsrecursive (or whatever the script is called) and then once the content has moved, use the remove-replica version to remove it.

Simon.
__________________
--
Simon Butler
Exchange MVP

Blog: http://blog.sembee.co.uk/
More Exchange Content: http://exchange.sembee.info/
Exchange Resources List: http://exbpa.com/
In the UK? Hire me: http://www.sembee.co.uk/

Sembee is a registered trademark, used here with permission.
  #3  
Old 19th February 2011, 16:55
outstream outstream is offline
Casual
Casual
 
 Join Date: Sep 2008
  6 month star 12 month star
 Posts: 51
 Reputation: outstream is on a distinguished road (15)
Default Re: Public folder migration - Exchange 2003 to Exchange 2010

Hi, thanks for your reply.

Seems like content replication isnt happening.

I have verified hierarchy replication by creating a new folder on exchange 2003 and then verifying it has been replicated to exchange 2010. The folder didnt have any item in it, so it had 0 items in exchange 2010 end aswell.

However, a whole bunch of other folders have items in them and they are just not replicating any content.

I`ve verified basic smtp connectivity by telnetting from each server to the other one. however, replies to smtp messages werent successful.

how can I troubleshoot this best?


Thanks much
  #4  
Old 20th February 2011, 19:09
Sembee's Avatar
MVP Sembee Sembee is offline
MVP
MVP
 
 Join Date: Apr 2006
  6 month star 12 month star
 Location: Newbury, UK
 Posts: 6,464
 Reputation: Sembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud ofSembee has much to be proud of (1116)
Default Re: Public folder migration - Exchange 2003 to Exchange 2010

If you are not getting responses to SMTP then that will stop replication of the data. It is a clear sign of interference.
Usual suspects are AV software that is scanning the SMTP port. Could also be restrictions on the Receive Connector, something changed on the receive connector to stop the connection being made.

Simon.
__________________
--
Simon Butler
Exchange MVP

Blog: http://blog.sembee.co.uk/
More Exchange Content: http://exchange.sembee.info/
Exchange Resources List: http://exbpa.com/
In the UK? Hire me: http://www.sembee.co.uk/

Sembee is a registered trademark, used here with permission.
Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 to 2010 exchange migration wattsup Exchange 2007 / 2010 / 2013 31 24th February 2011 05:05
migrate 2003 public folders to exchange 2010 b121262 Exchange 2007 / 2010 / 2013 2 7th December 2010 18:37
Trouble moving public folders from SBS 2003 Exchange to Exchange 2010 on Server 2008 arstacey Exchange 2007 / 2010 / 2013 12 19th July 2010 17:02
Public Folder Migration from 2007 to 2010 danny230681 Exchange 2007 / 2010 / 2013 2 7th May 2010 11:43
Exchange 2007 Public Folder items not replicating to 2003 Public Folders Craig_Han Exchange 2007 / 2010 / 2013 4 28th December 2008 03:48


All times are GMT +3. The time now is 06:41.

Steel Blue 3.5.4 vBulletin Style ©2006 vBEnhanced
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
 

Valid XHTML 1.0!   Valid CSS!

Copyright 2005 Daniel Petri